Новости Software

Серьёзная уязвимость Wordpress и Drupal затронула почти четверть сайтов в мире

Одни из самых популярных в наши дни систем управления содержимым сайтов и блогов — WordPress (с версии 3.5 по 3.9) и Drupal (с 6.x по 7.x.) — оказались подвержены очень опасной уязвимости, нарушавшей дальнейшую исправную работу сервера. По данным компании Salesforce.com, деятельность которой построена вокруг решения вопросов кибербезопасности, обнаруженная программная лазейка позволяла осуществить хакерскую атаку на интернет-ресурс и практически моментально заблокировать его работу при помощи лишь одного XML-документа.

В качестве оружия виртуального злоумышленника мог выступить небольшой файл размером с пару сотен килобайт, который в конечном итоге превращался в многогигабайтный документ и загружал всю доступную память сервера. После такого функционирование в привычном режиме становилось затруднительной задачей, а выбранный для атаки сайт на WоrdPress или Drupal практически моментально выводился из строя. 

Представители компании Salesforce, чтобы наглядно проинформировать общественность о существующей опасности для популярных «движков», позволяющих группировать контент и предоставлять инструменты для удобного создания и редактирования содержания страниц сайта, выложили в Сеть видеоподтверждение наличия уязвимости.

Разработчики Drupal и WordPress, в свою очередь, тут же отреагировали на озвученную проблему, предоставив владельцам сайта внеплановое обновление для как можно скорейшего устранения найденных «дыр» в их системах. 

Источник:

Если вы заметили ошибку — выделите ее мышью и нажмите CTRL+ENTER.
Материалы по теме
window-new
Soft
Hard
Тренды 🔥